Ford Focus Forum banner

381 - 391 of 391 Posts

·
Registered
Joined
·
153 Posts
BAD NEWS.....Going Going....GONE

Hate to post bad stuff...but as we say here in Tx....$#!* happens...the month of February wasn't nice

Day after I drove a Lamborghini Gallardo at work, better than sex, out making a burger run I got to confident and increased my corning speed by 30% at one corner I loved to cut the apex and feel the car lift and settle back down....well this time at near 60 it didn't settle. Rear end lifted to the point of no weight to grip road, tail end came around.....felt like slow motion but after 300ft crossed the curb, pruned 2 trees and shrubs in the median and landed heading same direction but other side of road, still drove it home(1/4 mile).

Damage, one badly twisted car, one bent strut, blown rear tire, cord busted on 2others, one good but they don't make them no more. MO6's bent, one untouched, right side wheels bent off center, RS bumper toast but I can rebuild it.

Trying to decide if I've got the ambition to do this again, lot of dog work, will need excellent donor car to consider, strip clean, transfer all to another car...or part out. Got the MK1 RS and a 2016 RS on order, house that I need to finish. These projects keep me so busy, FRS then SierraRS I've neglected the house.

If I had enough interest...I might part...otherwise need to find good donor that's worthy of the resurrection of one of the finest cars I've had







Drivers side...and yes the door is shut all the way...shows the twist in body...when looking from back of car, I can tell the roof line higher on pass side



The landscaping I did..entrance side



...exit side and the intersection I took the HAARD left hander

Sorry for your loss! Very similar to the end for my old SVT Focus
 

·
Registered
Joined
·
307 Posts
Even after a little bit of loss, there is soooo much win in this thread. Love it.

Sent from my SM-N910R4 using Tapatalk
 

·
Registered
Joined
·
1,681 Posts
Discussion Starter #385 (Edited)
If you didn't know I've got a new member to my RS Corral. I put my order in last Oct like most did. Build date came around, June 30, then the wait for delivery. Tracked the boat, rail system, and finilly the dealer called last Thursday with the good news..IT"S HERE!!
Now for some quick shots at NorthCentral Ford, here in Richardson, Tx









 

·
Registered
Joined
·
4 Posts
If you didn't know I've got a new member to my RS Corral. I put my order in last Oct like most did. Build date came around, June 30, then the wait for delivery. Tracked the boat, rail system, and finilly the dealer called last Thursday with the good news..IT"S HERE!!
Now for some quick shots at NorthCentral Ford, here in Richardson, Tx









Wow. Congrats they both look amazing
 

·
Registered
Joined
·
1,681 Posts
Discussion Starter #387 (Edited)
Been awhile since I've posted. Guilty as charged...been enjoying the new baby inn the family. Been driving less and less of the MK1, so decided to take the time to explore the cause of the noise the S/C has been making for 2years...see how long the putting something off can last. As suspected the drive coupler was at fault, but not destroyed as I thought, just one set of drive holes had elongated .050. That was making this horrendous rattling without load, once drive line engaged it goes away. Thought it would be hard to locate but turns out several manufactures used the same drive type units...eBay=$16 Went ahead and got a replacement so the whoever buys the kit will be set. It goes along with the new idlers to replace the original units. This SVT engine has used the kit since 2011, 34k miles plus the 12k from the 2003 SVTF.

Pics Soon...I think...frigen Photobucket is sooooo slooow, I need a better storage bank...this one needs to go in the bucket itself!!
 

·
Raving my tets aft
Joined
·
1,568 Posts
Been awhile since I've posted. Guilty as charged...been enjoying the new baby inn the family. Been driving less and less of the MK1, so decided to take the time to explore the cause of the noise the S/C has been making for 2years...see how long the putting something off can last. As suspected the drive coupler was at fault, but not destroyed as I thought, just one set of drive holes had elongated .050. That was making this horrendous rattling without load, once drive line engaged it goes away. Thought it would be hard to locate but turns out several manufactures used the same drive type units...eBay=$16 Went ahead and got a replacement so the whoever buys the kit will be set. It goes along with the new idlers to replace the original units. This SVT engine has used the kit since 2011, 34k miles plus the 12k from the 2003 SVTF.

Pics Soon...I think...frigen Photobucket is sooooo slooow, I need a better storage bank...this one needs to go in the bucket itself!!
I just recently switched to Flikr from photobucket as it has gotten terrible and ad ridden....

Nice work on the mk1 though! Mk3 must be a damn nice upgrade though!
 

·
Registered
Joined
·
1,861 Posts
This car is amazing!

I post so little anymore that I use Facebook for photos. I tried using Google Drive but image links from Google Drive can be a pain in the butt to get working right.
 
381 - 391 of 391 Posts
Top